My iZotope Product Crashes after Installing the latest Update (macOS 10.13 / 10.14)

Symptom

After installing the latest update in Product Portal, the following iZotope products can crash on macOS 10.13 and 10.14:

Cause

The latest updates of these products are not compatible with macOS 10.13 and 10.14 anymore. You can find their current system requirements on the above linked product pages.

Solution

In order to keep your products updated with the newest features and bug fixes, we highly recommend updating your operating system!

In the meantime, you can download the installers for the latest compatible product versions on macOS 10.13 and 10.14 below.

Important: After installing these versions, DO NOT update them again via Product Portal, until you have updated your operating system to macOS 10.15 or higher!