Symptom
When trying to use a plug-in from your Music Production Suite Pro subscription, the plug-in shows Missing Authorization / Trial Mode, while it appears to be authorized in Product Portal.
Cause
As of April 30, 2025, Native Access is the new, centralized hub to manage products in your Music Production Suite Pro subscription. This means you will no longer be able to use Product Portal to authorize / download products or access updates to your iZotope subscription.
Solution
- If you haven't already, set up your Native ID as explained in this article:
iZotope is switching to Native ID for signing in to your iZotope account - Download and install Native Access and log in with your Native ID.
- Open the Subscriptions tab:
- Now your Music Production Suite Pro products are authorized again.