Audiolens Error: “We have detected a missing or faulty installation"

Symptom

When attempting to open Audiolens, an error appears:

Something isn't right. We have detected a missing or faulty installation. Please re-run the installer.

audio lens error.PNG

Cause 

This issue can occur if one of the Audiolens components is missing or corrupted.

Solution

As a first step please run the uninstaller for Audiolens using the steps below. 

Mac

  1. Firstly close all running applications.
  2. You can then uninstall iZotope software by using an uninstall app that is provided in the following location:
    (Macintosh HD)/Library/Application Support/iZotope/ Audiolens
    The script is in the root-level Library folder, and not in the User-level Library folder.
  3. Once completed please reinstall following the steps in our ACE for audio lens setup guide linked below:
    Installing ACE for Audiolens on macOS

Windows

  1. Close all running applications.
  2. Enter your Windows Control Panel screen, and select "Uninstall a program" from the Programs category.
  3. In the next window, locate Audiolens in the list. Right-click it and choose "Uninstall."
  4. Restart your computer.
  5. Open Product Portal and install Audiolens again.